Digicert Certificate Issues

Incident Report for Enom

Resolved

The Digicert service outage has been resolved.
Posted Dec 04, 2023 - 03:18 PST

Identified

There is currently a service outage at Digicert impacting Enom's ability to process Digicert certificates.

This may impact the ability to purchase new certificates and submit CSRs.
Posted Dec 04, 2023 - 02:21 PST
This incident affected: SSL Certificates.