Hosted Email Service and Website down
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 14:26 PDT
Monitoring
Our dev team has implemented a fix. We will continue to monitor to make sure there are no further issues
Posted Apr 10, 2024 - 12:55 PDT
Update
We are continuing to investigate this issue.
Posted Apr 10, 2024 - 12:27 PDT
Update
We are continuing to investigate this issue.
Posted Apr 10, 2024 - 12:26 PDT
Investigating
We are currently investigating an issue with our hosted email service.

The following services are affected:

Webmail Access
Posted Apr 10, 2024 - 12:10 PDT
This incident affected: Enom.com (Website) and Basic Email Service.