Support center login issues
Incident Report for Enom
Resolved
Users should now be able to access the Help Center and manage Help Requests without issue. Thank you for your patience..
Posted Jun 22, 2017 - 09:51 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 22, 2017 - 00:35 PDT
Investigating
Customers are currently unable to sign in to the support center from https://www.enom.com/help/default.aspx or https://www.enomcentral.com/help/default.aspx to create or view new or existing cases. We are investigating the issue and will provide more information as it becomes available.
Posted Jun 22, 2017 - 00:26 PDT