CM Registry
Incident Report for Enom
Resolved
The Connection to the .CM registry has been fully restored.
Posted Oct 15, 2018 - 03:31 PDT
Identified
We are experiencing issues with our connection to the .CM registry. This affects the following aspects of domain management:

Availability Checks,
Whois Services,
Domain Purchases,
Domain Renewals,
Domain Updates,

DNS may continue to resolve, but changes will be unavailable at this time.
Posted Oct 14, 2018 - 12:37 PDT