CH LI maintenance
Incident Report for Enom
Resolved
SWITCH has completed scheduled maintenance. The CH and LI TLDs are up and running as expected.

Thank you.
Posted Oct 19, 2017 - 01:12 PDT
Monitoring
SWITCH, the CH and LI Registry, will be performing scheduled maintenance from 10:00 PM PST to 10:30 PM PST. During this time, management of these TLDs will be unavailable, including:

Registrations
Renewals
Transfers
DNS Changes

We will continue to monitor the maintenance window and update you if anything changes.

Thank you.
Posted Oct 18, 2017 - 22:02 PDT