.TW Registry
Incident Report for Enom
Resolved
Connections to the .tw registry have been restored and functionality has returned.
Posted 2 months ago. Apr 10, 2019 - 15:35 PDT
Investigating
We are experiencing issues with our connection to the .TW registry. This affects the following aspects of domain management:

Availability Checks,
Whois Services,
Domain Purchases,
Domain Renewals,
Domain Updates,

DNS will continue to resolve, but changes will be unavailable at this time.
Posted 2 months ago. Apr 10, 2019 - 15:21 PDT
This incident affected: Domain Services (Other ccTLDs).