RAA Verification Emails
Incident Report for Enom
Resolved
This incident has been resolved. RAA emails are being sent and verified as intended
Posted Feb 29, 2024 - 07:33 PST
Update
We are continuing to investigate this issue.
Posted Feb 28, 2024 - 19:40 PST
Investigating
We are currently investigating an issue regarding RAA Verification emails - Clients will not be able to verify registrant information at the moment
Posted Feb 28, 2024 - 18:27 PST
This incident affected: Domain Services (Core gTLDs, Other gTLDs).