The .EU connection issue has been confirmed resolved. All services are online.
Posted Nov 20, 2024 - 11:32 PST
Monitoring
Our .EU registry connection has been stable for some time now, with all services currently online. We continue to monitor this at this time.
Posted Nov 20, 2024 - 08:00 PST
Update
We are continuing to have connection issues with the .EU Registry. We are waiting for any updates, and will keep you informed as they're made available to us.
Posted Nov 20, 2024 - 06:25 PST
Investigating
We are currently experiencing connection issues with the .EU registry. We have been notified by the .EU Registry, they are currently experiencing technical issues and are working to resolve them as quickly as possible.
We will keep you informed of any updates as they work to identify and resolve this issue.
Posted Nov 20, 2024 - 05:17 PST
This incident affected: Domain Services (Core ccTLDs).