DigiCert Service Interruption
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 17:18 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 13, 2021 - 16:14 PST
Identified
There currently is a known issue at DigiCert that is being fixed. During this time customers may see issues with purchasing or managing their Digicert SSLs. We will provide any updates that we receive.
Posted Jan 13, 2021 - 10:28 PST
This incident affected: SSL Certificates.