Enom Hosted Email Service Degradation
Incident Report for Enom
Resolved
Our engineering team has resolved the issue and email is being sent through our servers normally. Thank you for your patience.
Posted Jun 07, 2021 - 15:47 PDT
Monitoring
Our engineering team has completed the work to resolve the issue. We will continue to monitor for further problems.
Posted Jun 07, 2021 - 15:11 PDT
Identified
Our Engineers have identified the issue and are working towards a resolution. Estimated time of completion is 1 hour.

We will continue to provide updates as they are made available and thank you for your ongoing patience.
Posted Jun 07, 2021 - 13:53 PDT
Investigating
We are currently experiencing some issues with our hosted email service. Some users may have issues logging in as well as see some sending and receiving delays. We thank you for your patience as we continue to investigate the issue.
Posted Jun 07, 2021 - 12:54 PDT
This incident affected: Basic Email Service.