Digicert Outage
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Mar 15, 2023 - 15:40 PDT
Monitoring
A fix has been implemented. We are monitoring to make sure that there are no further issues.
Posted Mar 15, 2023 - 14:20 PDT
Investigating
Digicert is currently experiencing a service outage. They have identified the issue and a fix is being implemented.

This outage may impact new orders and renewals. Existing orders are not impacted at this time.
Posted Mar 15, 2023 - 13:49 PDT
This incident affected: SSL Certificates.