Sectigo SSL processing
Incident Report for Enom
Resolved
A resolution has been implemented and Sectigo SSL orders have begun to process as intended. Thank you for your patience while we worked towards resolving the problem.
Posted Oct 27, 2020 - 10:29 PDT
Investigating
We have been made aware of delays in order processing of Sectigo SSL certificates. Currently, users may see "pending processing" in place of a reference number, or no reference number at all.

We are investigating the cause of the problem, and working as quickly as possible to resolve the issue. We will post more information as it comes available.
Posted Oct 27, 2020 - 04:50 PDT
This incident affected: SSL Certificates.