Centralnic Registry connection issues
Incident Report for Enom
Resolved
Services have returned to operational status. Customers are able to check availability and manage domains from these TLDs without further difficulty.
Posted Nov 17, 2021 - 18:28 PST
Update
We are experiencing connectivity issues with the Centralnic Registry and have contacted the registry to determine the root cause of the issue.

Customers will not be able to check availability, register or renew domains from the following gTLDs: .CEO, .BEST, .UNO and .LONDON.

Thank you for your patience.
Posted Nov 17, 2021 - 16:48 PST
Investigating
We are currently investigating this issue.
Posted Nov 17, 2021 - 16:38 PST
This incident affected: Domain Services (Other gTLDs).