Customer Service phone line incident

Incident Report for Enom

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 15:24 PDT

Investigating

We are currently experiencing issues receiving and sending calls from our phone lines but chat and Email services are still operating normally. We're currently investigating the incident.
Posted Jun 12, 2025 - 12:18 PDT
This incident affected: Customer Support.