EU Registry
Incident Report for Enom
Resolved
Our connection to EU registry has been restored.
Posted 8 days ago. Apr 11, 2019 - 05:28 PDT
Monitoring
Our connection is recovering. We will continue to monitor the situation until fully resolved.
Posted 8 days ago. Apr 11, 2019 - 05:23 PDT
Investigating
We are investigating reports that the EU registry is having connection issues. This will affect the following for EU domains:

Registrations
Renewals
Transfers
Contact management
DNS Management

Currently active domains should still resolve as normal.
Posted 8 days ago. Apr 11, 2019 - 05:20 PDT