Hosted Email Service Degradation
Incident Report for Enom
Resolved
This issue has been resolved.
Posted Jan 14, 2022 - 13:14 PST
Monitoring
Our team has applied a fix and customers should be able to create new users through their email manager once again. We will continue to monitor the case to see if there are any further issues.
Posted Jan 14, 2022 - 10:55 PST
Investigating
We are currently investigating an issue where customers are having problems creating new email forwards and users in their email manager. We appreciate your patience as we investigate the issue further.
Posted Jan 14, 2022 - 10:05 PST
This incident affected: Basic Email Service.