Hostedemail Login Issues
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Feb 22, 2024 - 08:48 PST
Investigating
We are currently looking into an issue where customers are seeing intermittent issues of not being able to access their webmail through mail.enom.com and sending and receiving through their mail clients. We thank you for your patience as we work on a fix.
Posted Feb 22, 2024 - 07:27 PST
This incident affected: Basic Email Service.