.MS Registry Connection Issues
Incident Report for Enom
Resolved
The connection between .ms TLD and Enom has been restored
Posted Sep 18, 2022 - 15:30 PDT
Update
We are experiencing connectivity issues with the .MS Registry.

This will impact the ability to register, renew, update and check the availability for .MS domains.
Posted Sep 17, 2022 - 21:27 PDT
Investigating
We are experiencing connection issues to the registry. We will provide an update shortly with additional information.
Posted Sep 17, 2022 - 14:53 PDT
This incident affected: Domain Services (Other ccTLDs).