ES registry Maintenance
Incident Report for Enom
Resolved
The maintenance at the with the .es Registry as been completed.
Posted Mar 13, 2024 - 16:50 PDT
Identified
The ES Registry is undergoing maintenance at the moment:

Affected services:
Domain management of .ES domains

We're keeping an eye on their maintenance for when this is completed.
Posted Mar 13, 2024 - 14:52 PDT
This incident affected: Domain Services (Core ccTLDs).