Order Processing Delays
Incident Report for Enom
Resolved
Order processing delays have been identified and resolved at this time. Orders will be processed normally at this time.
Posted Mar 21, 2018 - 06:50 PDT
Investigating
Some users may experience issues with renewals and other orders being delayed. We are currently investigating and are working to resolve as quickly as possible.

You should not have to submit the order again unless you get a notification via email that the order failed.
Posted Mar 20, 2018 - 15:32 PDT