Enom Webmail Login Issues
Incident Report for Enom
Resolved
Email service has been restored and stable for over 24 hours now. We're calling this resolved. Thank you so much for your continued patience.
Posted Mar 28, 2020 - 05:27 PDT
Update
The maintenance that was preformed last night and throughout the day today has stabilized the ongoing email issue.

We understand how much this has inconvenienced those affected by this issue and we deeply apologize.

We will continue to monitor the fixes currently in place until we can confirm that everything is working as expected again; we will provide further updates here.

Thank you again for your continued patience.
Posted Mar 26, 2020 - 17:51 PDT
Update
Aside from a small subset of users, the issues affecting mailbox connection interruptions, mail delivery delays, and the inability to sign in have been fixed.

We will continue to monitor the stability as well as for confirmation that the subset of users are working as intended.

Thank you for your ongoing patience.
Posted Mar 26, 2020 - 14:32 PDT
Update
We have verified reports of logins failing via POP. Due to this our operations team has had to make corrections which may affect more users.

Some users may experience intermittent mailbox connection interruptions, mail delivery delays, or inability to sign in.

We continue to work towards a resolution.
Posted Mar 26, 2020 - 12:05 PDT
Update
After maintenance, a vast majority of our Email services were restored and are operational. A small subset of users may still experience issues when attempting to log into their Webmail.

Our team continues to work towards a full resolution.
Posted Mar 26, 2020 - 10:03 PDT
Monitoring
Our Email services will be undergoing maintenance today from 3PM PDT until the following morning at 3AM PDT to improve long-term stability and address recent issues. During this period some users may experience intermittent mailbox connection interruptions, mail delivery delays, or inability to sign in.

We will continue to monitor the impact during the maintenance window and provide further updates once completed.

Thank you to all users for your ongoing patience.
Posted Mar 25, 2020 - 14:15 PDT
Update
We've made updates to restore access for the users previously unable to check email and we are monitoring the results.
Posted Mar 25, 2020 - 11:09 PDT
Update
We are starting to see email interruptions again this morning. Connections to our email service may be disrupted and sign-in attempts may fail for some users. Your mail will not be lost during this time and will be available once you are able to sign in again.
Posted Mar 25, 2020 - 07:19 PDT
Update
We continue to work on this issue and are making good progress. We will update you again shortly. Thank you for your continued patience.
Posted Mar 25, 2020 - 03:04 PDT
Update
We expect email service interruptions to continue while we actively work on a long-term fix. A small percentage of users will be unable to log in to mail at the moment. Mail is still being delivered and will be there when you are next able to sign in. Other users may experience slowness or intermittent sign-in errors.
Posted Mar 24, 2020 - 20:44 PDT
Update
Our work to resolve this matter is continuing.

Email service interruptions may continue while we actively work on a long-term fix. A small percentage of users will be unable to log in to mail at the moment; other users may experience slowness or intermittent sign-in errors.

Thank you again for your patience.
Posted Mar 24, 2020 - 17:05 PDT
Update
Our progress to a full resolution is still underway.

We expect email service interruptions to continue while we actively work on a long-term fix. A small percentage of users will be unable to log in to mail at the moment; other users may experience slowness or intermittent sign-in errors.

Mail is still being delivered and will be there when you are next able to sign in.
Posted Mar 24, 2020 - 14:43 PDT
Update
Progress towards a full resolution continues.

We expect email service interruptions to continue while we actively work on a long-term fix. A small percentage of users will be unable to log in to mail at the moment. Mail is still being delivered and will be there when you are next able to sign in. Other users may experience slowness or intermittent sign-in errors.
Posted Mar 24, 2020 - 11:57 PDT
Update
We expect email service interruptions to continue while we actively work on a long-term fix. A small percentage of users will be unable to log in to mail at the moment. Mail is still being delivered and will be there when you are next able to sign in. Other users may experience slowness or intermittent sign-in errors.
Posted Mar 24, 2020 - 06:37 PDT
Update
We continue to work on this issue as quickly as possible. We have implemented a fix and are seeing improvement over time. We will update you again as soon as possible. We again appreciate your patience.
Posted Mar 24, 2020 - 04:27 PDT
Update
Our development team continues work on this issue, and have implemented measures to begin to resolve the issue. We will update you With any new information as it becomes available. Thank you for your patience.
Posted Mar 23, 2020 - 23:48 PDT
Update
Our work to resolve this issue is continuing, any new information will be shared here as it becomes available.

Thank you for your continued patience.
Posted Mar 23, 2020 - 20:53 PDT
Update
Thank you for your continued patience while we work to resolve this matter.
Posted Mar 23, 2020 - 19:06 PDT
Update
We are continuing to work on this issue and will provide additional details as they become available.

Thank you for your continued patience.
Posted Mar 23, 2020 - 16:59 PDT
Update
We thank you for your continued patience.

Our team is working diligently to resolve this issue, we will continue to provide updates here.

Currently users may be unable to access their account via Webmail, IMAP or POP.
Posted Mar 23, 2020 - 15:52 PDT
Update
We are continuing our work towards a resolution. Users may be unable to access their account via Webmail, IMAP or POP.

Thank you for your continued patience.
Posted Mar 23, 2020 - 14:39 PDT
Update
We continue to work towards a resolution. Users may be unable to access their account via Webmail, IMAP or POP.
Posted Mar 23, 2020 - 13:32 PDT
Update
We continue to work on our Email login issues. Currently users may be unable to access their account via Webmail, IMAP or POP. Thank you for your ongoing patience.
Posted Mar 23, 2020 - 12:04 PDT
Update
We are continuing to work on this issue. We thank you for your continued patience.
Posted Mar 23, 2020 - 11:12 PDT
Identified
We are still investigating this issue. Customers may continue to have issues logging in or accessing their webmail at this time. We that you for your continued patience.
Posted Mar 23, 2020 - 09:01 PDT
Investigating
We are currently investigating an issue where some Enom webmail users will have issues logging in. This is being worked on by our dev team and should not affect all users. We thank you for your patience with this case.
Posted Mar 23, 2020 - 07:51 PDT
This incident affected: Basic Email Service.