Digicert API (Geotrust and Symantec SSL)
Incident Report for Enom
Resolved
The issue has now been resolved.
Posted 18 days ago. Jun 28, 2019 - 00:00 PDT
Investigating
Geotrust and Symantec are currently experiencing API issues. Current SSL services impacted: purchases, replacements and revocations.

We will update you once we have more information. Thank you for your patience.
Posted 18 days ago. Jun 27, 2019 - 20:34 PDT
This incident affected: SSL Certificates.