Sectigo SSL certificates
Incident Report for Enom
Resolved
This incident has been resolved. Thank you.

Incident Start Time: 09-30-2022 17:40:00
Incident End Time:09-30-2022 18:14:00
Total Duration:34 minutes
Posted Sep 30, 2022 - 15:28 PDT
Investigating
We are currently investigating issues with submitting new Sectigo SSLs. Users submitting a CSR for an SSL orders may get "“error -the remote server returned an error - internal server error" among other errors.

our operations team is investigating the issue. We will update you shortly. Thank you.
Posted Sep 30, 2022 - 14:50 PDT
This incident affected: SSL Certificates.