Webmail - Degraded Performance
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Nov 06, 2024 - 14:06 PST
Update
We are actively monitoring for any further issues.
Posted Nov 06, 2024 - 07:09 PST
Monitoring
A fix has been implemented and we are monitoring the results
Posted Nov 06, 2024 - 04:37 PST
Update
We are continuing to investigate this issue.
Posted Nov 06, 2024 - 04:07 PST
Investigating
We are investigating an issue impacting Cluster A webmail. This can present as slow loading or login issues.
Posted Nov 06, 2024 - 03:58 PST
This incident affected: Basic Email Service.