Hosted email
Incident Report for Enom
Resolved
We discovered and fixed an issue that was causing server errors when accessing email or webmail for a small number of accounts. Email service is now fully restored. Sorry about that!
Posted Mar 28, 2020 - 13:34 PDT
Investigating
Some users are receiving errors when connecting to email or webmail. We're looking into it and will have updates as soon as possible.
Posted Mar 28, 2020 - 12:48 PDT
This incident affected: Basic Email Service.