enom.com website degradation
Incident Report for Enom
Resolved
We have had no service interruption or degradation, our engineering team has confirmed that all services are fully operational. We will be closing this incident.
Posted Sep 20, 2020 - 05:50 PDT
Monitoring
All services have recovered and mitigation is still in place and running. This issue has been resolved, but We will keep monitoring for stability.
Posted Sep 19, 2020 - 21:08 PDT
Identified
Our engineering teams are continuing to implement mitigation on the blocks receiving abusive traffic, enom.com, name servers, and API are still currently experiencing service degradation.
Posted Sep 19, 2020 - 14:05 PDT
Update
We are continuing to investigate this issue.
Posted Sep 19, 2020 - 13:37 PDT
Investigating
We are also reporting that Enom API is affected. Customers may expect errors when running API calls. Engineering continues to mitigate abusive traffic.
Posted Sep 19, 2020 - 13:29 PDT
Identified
We are seeing abusive traffic hitting our servers impacting enom.com, our engineers are working to mitigate service impact.
Posted Sep 19, 2020 - 13:13 PDT
This incident affected: Enom.com (Website) and API, DNS Service, Customer Support.