Hosted Email Service Degredation
Incident Report for Enom
Resolved
This case has been resolved
Posted Jul 23, 2024 - 07:23 PDT
Monitoring
Our team has identified the issue and have implemented a fix. We will continue to monitor to make sure that there are no other issues.
Posted Jul 23, 2024 - 06:48 PDT
Investigating
We are currently seeing delays with hosted email with some slowness on incoming mail. We thank you for your patience as our team works on a fix.
Posted Jul 23, 2024 - 06:39 PDT
This incident affected: Basic Email Service.