Digicert Trust Orders

Incident Report for Enom

Resolved

Digicert reports this issue is now resolved. We have confirmed submitted orders are now being processed as expected.
Thank you for your patience.
Posted Jun 23, 2025 - 07:53 PDT

Monitoring

There is an API submission issue preventing placing or cancelling orders to Digicert. They are aware of this issue and are working on a fix on their end.

We will post any updates as they work to resolve this.
Posted Jun 23, 2025 - 06:38 PDT
This incident affected: SSL Certificates.