.org .pro .info .mobi .archi Registry Connections
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 02:57 PST
Investigating
We are currently experiencing connection issues with the .org .pro .info .mobi .archi registries. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .org .pro .info .mobi .archi domains. Existing domains will continue to resolve normally
Posted Nov 17, 2020 - 02:20 PST
This incident affected: Domain Services (Core gTLDs, Other gTLDs).