Phone Support Degredation
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Oct 08, 2024 - 17:26 PDT
Monitoring
We are continuing to monitor for any further issues.
Posted Oct 08, 2024 - 14:07 PDT
Investigating
Our phone service provider has indicated that the earlier issue has regressed. This may affect customers' ability to reach us by phone. We encourage you to connect with us via chat or email for assistance. Thank you for your understanding.
Posted Oct 08, 2024 - 13:52 PDT
This incident affected: Customer Support.