HostedEmail - Service Degraded
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Oct 19, 2021 - 13:31 PDT
Monitoring
Users are able to send outbound emails successfully again. Please re-login and test outbound emails.
Posted Oct 19, 2021 - 11:57 PDT
Investigating
We are currently investigating HostedEmail service degradation. Users may receive the "SMTP Error (554): Failed to add recipient" error and be unable to send emails.
Posted Oct 19, 2021 - 11:11 PDT
This incident affected: Basic Email Service.