.SG Registry
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Feb 25, 2021 - 03:39 PST
Monitoring
This issue has been resolved. We have reached out to the Registry for cause, and will update you if we receive more information. We will also monitor this issue for stability before closing. Thank you.
Posted Feb 25, 2021 - 00:00 PST
Investigating
We are experiencing issues with our connection to the .SG registry.

During this outage, you may experience issues with :

Registration
Renewals
Transfers
Contact Management
DNS server changes

We have reached out to the Registry for assistance with the matter. We will update you as more information is available.
Posted Feb 24, 2021 - 23:08 PST
This incident affected: Domain Services (Other ccTLDs).