sg. Registry Maintenance
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Mar 27, 2024 - 13:00 PDT
Investigating
The SG registry is currently under maintenance until 03/25/2024 12:00 UTC:

https://www.sgnic.sg/announcements/sgnic-news/announcement-details/2024/03/15/important-notice-revamp-of-sgnic's-registry-platform

During this system maintenance, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates
Posted Mar 24, 2024 - 14:54 PDT
This incident affected: Domain Services (Core ccTLDs).