.IT Registry Connection Issues
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Feb 01, 2023 - 07:40 PST
Investigating
We are currently experiencing intermittent connection issues with the .IT registry. During this time, customers may experience issues with registrations and renewals of their .it domains. Thank you for your patience as we investigate this further.
Posted Feb 01, 2023 - 07:19 PST
This incident affected: Domain Services (Other ccTLDs).