Hosted Email Service Degradation
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Dec 01, 2024 - 17:09 PST
Monitoring
Webmail functionality is restored. We will monitor for any changes
Posted Dec 01, 2024 - 16:39 PST
Investigating
We are seeing intermittent service disruptions for cluster A webmail. Engineers are already investigating
Posted Dec 01, 2024 - 15:59 PST
This incident affected: Basic Email Service.