HostedEmail - Inbound/Outbound Delay
Incident Report for Enom
Resolved
This incident has been resolved.
Posted May 26, 2020 - 05:57 PDT
Monitoring
Our operations team was able to resolve the issue causing inbound and outbound delays. We will continue to monitor for further reports.
Posted May 26, 2020 - 05:23 PDT
Investigating
We are currently investigating an outage affecting inbound and outbound email. Users email will be queued to send but may see a delay.

Thank you for your patience.
Posted May 26, 2020 - 05:00 PDT
This incident affected: Basic Email Service.