Hosted email
Incident Report for Enom
Resolved
You should no longer encounter authentication issues when trying to sign in to hosted email. Apologies for the interruption.
Posted Mar 21, 2020 - 07:41 PDT
Investigating
A handful of users may be unable to sign in to their hosted email accounts via webmail or email client. You may see errors about a "bad login". We're looking into it.
Posted Mar 21, 2020 - 06:03 PDT
This incident affected: Basic Email Service.