.TW registry connection issue

Incident Report for Enom

Update

The registry has responded letting us know they are investigating this issue. We'll continue posting updates on this case as they're available.
Thank you for your patience.
Posted Jun 30, 2025 - 09:01 PDT

Update

We are still waiting on a response from the registry on this .TW registry connection issue. We will post any updates as they become available.
Thank you for your patience.
Posted Jun 30, 2025 - 08:01 PDT

Investigating

We are experiencing an issue with its connection to the .TW registry. Renewals and domain management are affected. We have reached out to the registry for further information and will provide more details when they are available.
Posted Jun 28, 2025 - 09:53 PDT
This incident affects: Domain Services (Other ccTLDs).