.TW Registry Connections
Incident Report for Enom
Resolved
The .tw registry has restored their connections. Registration and management of .tw domains have returned to normal.
Posted May 31, 2020 - 01:58 PDT
Investigating
We are currently experiencing connection issues with the .TW registry. Our operations team is investigating the issue.

This affects:
Registrations
Renewals
Contact management

Existing domains will continue to resolve normally
Posted May 31, 2020 - 01:31 PDT
This incident affected: Domain Services (Other ccTLDs).