.biz, .tel, .us Registry
Incident Report for Enom
Resolved
This case has been resolved. The tlds should be functioning as normal.
Posted Nov 15, 2021 - 07:17 PST
Update
Our team is continuing to investigate this case. We thank you for your continued patience.
Posted Nov 15, 2021 - 05:20 PST
Update
We are experiencing connection issues with TLDs us, biz and tel. We have reached out to the registry for more information.

While the issue is ongoing, you may experience problems attempting to register, renew, manage contacts, transfer, and perform DNS server changes on any domains with these TLDs.
Posted Nov 15, 2021 - 01:18 PST
Investigating
We are currently investigating this issue.
Posted Nov 15, 2021 - 01:10 PST
This incident affected: Domain Services (Other gTLDs).