Enom Hosted Email Service Degradation
Incident Report for Enom
Resolved
No reports of further degradation, Enom email customers email services should be fully functional.
Posted 3 days ago. Sep 12, 2019 - 19:21 PDT
Monitoring
Our Email connections have stabilized. We are monitoring the to ensure no further degradation occurs. Thank you for your ongoing patience.
Posted 3 days ago. Sep 12, 2019 - 14:18 PDT
Investigating
Enom Email customers may see some connectivity issues with their hosted mail. Services may be functioning slower than usual due to degraded services.

We appreciate your patience while we investigate this issue further.
Posted 3 days ago. Sep 12, 2019 - 13:17 PDT
This incident affected: Basic Email Service.