CIRA Registry Connection Issues
Incident Report for Enom
Resolved
Our connection has been restored. This incident has been resolved.
Posted Nov 20, 2020 - 11:48 PST
Update
We are seeing connection issues with CIRA at this time. Customers may not be able to renew, register, and update CIRA domains ( fury, kiwi, ca, sx) TLDs. Thank you for your patience with this case.
Posted Nov 20, 2020 - 10:49 PST
Investigating
We are experiencing connection issues to the registry. We will provide an update shortly with additional information.
Posted Nov 20, 2020 - 10:44 PST
This incident affected: Domain Services (Core ccTLDs, Other gTLDs, Other ccTLDs).