Sectigo SSL Certificate Order Degredation
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Jan 13, 2020 - 08:52 PST
Investigating
We are currently looking into an issue where Sectigo SSL orders may not be going through. Our dev team is looking into our connection with the SSL provider. We appreciate your patience with this case.
Posted Jan 13, 2020 - 08:21 PST
This incident affected: SSL Certificates.