Hosted Email Service Degredation
Incident Report for Enom
Resolved
The HostedEmail service has been fixed and Webmail/Pop/IMAP connections have been restored.
Posted Dec 01, 2024 - 13:13 PST
Update
We are continuing to work on this issue.
Posted Dec 01, 2024 - 12:03 PST
Identified
Our engineering team continues to work on the issue. Further updates will be provided as they become available.
Posted Dec 01, 2024 - 09:51 PST
Investigating
We are currently investigating HostedEmail service degradation impacting a limited number of users. Some users may be unable to log in or access emails through Webmail at this time.

They are currently investigating and will provide updates as they come. Thank you for your patience.
Posted Dec 01, 2024 - 06:15 PST
This incident affected: Basic Email Service.