HostedEmail - Degraded
Incident Report for Enom
Resolved
Services are fully recovered, no issues have been noted during monitoring, no new customer complaints have been received. This incident is now resolved.
Posted Nov 14, 2024 - 11:32 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2024 - 10:00 PST
Update
Currently, users who are already logged in to their webmail/web client will experience slowness/degradation. Users who are trying to login, or have not yet logged in will be unable to.

Teams continue to investigate the issue.
Posted Nov 14, 2024 - 08:12 PST
Investigating
We have received reports of some users having intermittent issues accessing webmail. Teams have been engaged and are investigating.
Posted Nov 14, 2024 - 06:46 PST
This incident affected: Basic Email Service.