.ES Registry

Incident Report for Enom

Resolved

This incident has been resolved.
Posted Mar 11, 2023 - 13:58 PST

Monitoring

The registry has confirmed earlier maintenance has continued longer than expected. We will provide updates as they are made available.

Thank you for your patience.
Posted Mar 11, 2023 - 12:26 PST

Update

We are continuing to investigate this issue.
Posted Mar 11, 2023 - 09:16 PST

Investigating

We are currently investigating connection issues with the .ES registry. This affects registrations, renewals, and management of .ES domains. Existing domains will continue to resolve normally.
Posted Mar 11, 2023 - 09:16 PST
This incident affected: Domain Services (Other ccTLDs).