HostedEmail - Degraded
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 20:49 PST
Monitoring
Our email team has applied a fix for the earlier issues, and all impacted services appear to be restored. We will continue to monitor this incident and provide any further updates. Thank you for your patience.
Posted Nov 14, 2024 - 20:26 PST
Investigating
We are currently receiving an increasing number of reports from users experiencing webmail login/loading failures. Our engineering team is actively investigating the issue. We'll provide more updates as they become available.
Posted Nov 14, 2024 - 15:07 PST
This incident affected: Basic Email Service.