Domain Registrations and Updates
Incident Report for Enom
Resolved
We have deployed a fix to resolve the issue.

Thank you for your patience.
Posted 2 months ago. Feb 05, 2019 - 09:47 PST
Update
We are continuing to investigate this issue.
Posted 2 months ago. Feb 05, 2019 - 09:34 PST
Investigating
We are currently experiencing issues with new registrations and updates to existing domain registration and name servers.

We are investigating and will update you as soon as we know more
Posted 2 months ago. Feb 05, 2019 - 09:33 PST