Bad Username and Password Error
Incident Report for Enom
Resolved
Everything should be good to go now. Thank you so much for bearing with us through this.
Posted Oct 08, 2018 - 18:35 PDT
Identified
Our developers continue investigating this issue and have determined that it is DB Related, this may also affect account reporting when logged in, as well as DNS updates. Current DNS will still continue to resolve. We will provide more information as it becomes available.
Posted Oct 08, 2018 - 14:25 PDT
Investigating
We are currently seeing an issue where Enom account password updates are not saving properly when resetting through "forgot my password". This is currently being looked at by our Dev team.

Thank you for your patience with this matter.
Posted Oct 08, 2018 - 12:42 PDT
This incident affected: Enom.com (Website).