Phone Support Degredation
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Sep 18, 2024 - 15:43 PDT
Monitoring
A fix has been implemented at our service provider. We will be monitoring to make sure that there are no further issues.
Posted Sep 18, 2024 - 13:42 PDT
Investigating
We are currently seeing some service degradation with our phone support provider. Customers may have issues reaching out to Enom Support or experience disconnects when calling in. We hope to have a resolution at our provider soon.
Posted Sep 18, 2024 - 13:23 PDT
This incident affected: Customer Support.